Dobrodošli na FOSS Srbija

Free and Opensource Srbija je skup entuzijasta i ljubitelja slobodnog i otvorenog koda. Cilj nam je okupiti sve istomišljenike na jednom mestu i stvoriti najveći globalni OpenSource projekat u Srbiji i šire!

  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Ostali sistemi Elementary OS Luna

Discussion in 'Debian, LinuxMint, Ubuntu' started by tuks, 13.02.2013.

  1. Lazar

    Saradnik

    Joined:
    01.09.2013
    Messages:
    551
    Likes Received:
    318
    Okruženje:
    KDE 5
    Sistem:
    Arch
    Nisam probao, ali mi nikada neće biti jasno, zašto su npr. Mint i eOS bazirani na Ubuntu, a ne na Debianu.
     
  2. Dragan

    Staff Member

    Joined:
    13.01.2012
    Messages:
    7,246
    Likes Received:
    4,817
    Location:
    jóhonaaʼéí
    Okruženje:
    XFCE
    Sistem:
    TRIOS
    Debian je, zbog svoje filozofije i FOSS ideologije, oduvek bio malo teži za konfigurisanje..nedostatak non-free, vlasničkih drajvera u repoima, raznorazni kodeci, takođe non-free..sprečavali su nove i neiskusne korisnike da se upuštaju u podešavanje sistema. Ubuntu je to prvi iskoristio, dodao drajvere/kodeke i programe za podešavanje sistema u Debian, formirao i repoe i bazu korisnika, i enormno olakšao korišćenje linuxa, kako novajlijama, tako i iskusnim korisnicima.
    Prvi Mint je bio samo malo prepodešeni ubuntu, dodatno unapređen nekim video/audio kodecima koji nisu po difoltu bili instalirani u ubuntu.
    Kasnije se ta moda proširila, pa svi jašu jedni druge, a svi zajedno Debian..doduše, ponekad se malo i okliznu u koncepciji, pa im je teško da izbegnu tuntu kao posrednika..klasičan primer je taj Eos koji sada muku muči, jer ne može tako lako da se prebaci direktno na Debian, i izbaci tuntu kao posrednika :)
     
    Lazar likes this.
  3. Lazar

    Saradnik

    Joined:
    01.09.2013
    Messages:
    551
    Likes Received:
    318
    Okruženje:
    KDE 5
    Sistem:
    Arch
    To ima smisla, ali posle malo mučenja, nije ni Debian tako težak, kao npr. Gentoo ::)
    Mada kad malo bolje razmislim mnogima je tesko i Mint da podese :(
     
    Dragan likes this.
  4. Dragan

    Staff Member

    Joined:
    13.01.2012
    Messages:
    7,246
    Likes Received:
    4,817
    Location:
    jóhonaaʼéí
    Okruženje:
    XFCE
    Sistem:
    TRIOS
    Ništa nije teško kada znaš, i sve je teško kada ne znaš :)

    Debian ne da nije težak, nego je smešno lagan za podešavanje u poređenju sa nekim drugim unixima :)

    Na kraju krajeva, sve zavisi od potreba, volje i spremnosti da se nešto novo nauči :)
     
    Jo, Tanja and Filip like this.
  5. Filip

    Korisnik

    Joined:
    21.07.2012
    Messages:
    3,297
    Likes Received:
    1,600
    Location:
    Beograd
    Okruženje:
    XFCE
    Sistem:
    TRIOS
    @Pantheon na Debianu:

    GSoC se zavrsio, samo nikako da neko objavi rezultate vezane za Panteliju
     
    Collapse Signature Expand Signature
  6. Dragan

    Staff Member

    Joined:
    13.01.2012
    Messages:
    7,246
    Likes Received:
    4,817
    Location:
    jóhonaaʼéí
    Okruženje:
    XFCE
    Sistem:
    TRIOS
    Upravo sam krenuo da isprobavam neku vratolomiju...prebacujem se na sid, dodajem tuntu repoe, pa ke vidime šta će ispadne :)
     
    Filip likes this.
  7. Filip

    Korisnik

    Joined:
    21.07.2012
    Messages:
    3,297
    Likes Received:
    1,600
    Location:
    Beograd
    Okruženje:
    XFCE
    Sistem:
    TRIOS
    :huh: :negative:
    Pa to, nismo ovde da pomognemo ljudima, nego da ih ubedjujemo koliko ne znaju.... ::)

    @Skolski:
    :good2:
    Btw, mozda bolje da probas na Viziki, posto je "najblizi" 12.04 ubuntu-u ( baza eOS Lune ) :)
     
    Collapse Signature Expand Signature
  8. Dragan

    Staff Member

    Joined:
    13.01.2012
    Messages:
    7,246
    Likes Received:
    4,817
    Location:
    jóhonaaʼéí
    Okruženje:
    XFCE
    Sistem:
    TRIOS
    Mislim da je bolja opcija preko unstable..ako uspe(mo), dopunim zavisne pakete u naš repo, i nabacimo i tog Panteliju u TRIOS za igranje :)
    12.04 je mnogo mator...

    ------
    root@buildmach:~/Desktop# uname -a
    Linux buildmach 3.16-1-amd64 #1 SMP Debian 3.16.2-3 (2014-09-13) x86_64 GNU/Linux
    root@buildmach:~/Desktop#
     
    Filip likes this.
  9. Filip

    Korisnik

    Joined:
    21.07.2012
    Messages:
    3,297
    Likes Received:
    1,600
    Location:
    Beograd
    Okruženje:
    XFCE
    Sistem:
    TRIOS
    Nece moci sve. Wingpanel zavisi od ubuntu indicator-a kojih naravno u Debianu nema ( zamena za system tray ), + verovatno sto sta usput ( Geary mail moguce, slingshot launcher itd ), zato i cela prica/ideja o portovanju @GSoC... No ne bitno, panel moze koji god, ako (najbitnije) ostalo prodje. :)
    U svakom slucaju :fige: :D

    Edit:

    https://code.launchpad.net/pantheon-debian
     
    Collapse Signature Expand Signature
    Dragan likes this.
  10. Dragan

    Staff Member

    Joined:
    13.01.2012
    Messages:
    7,246
    Likes Received:
    4,817
    Location:
    jóhonaaʼéí
    Okruženje:
    XFCE
    Sistem:
    TRIOS
    Stigoh do faze da rešavam dep :)
    -----------
    root@buildmach:~/Desktop# apt install elementary-desktop
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:

    The following packages have unmet dependencies:
    elementary-desktop : Depends: elementary-artwork but it is not going to be installed
    Depends: ubuntu-drivers-common but it is not installable
    Depends: ubuntu-extras-keyring but it is not installable
    Recommends: acpi-support but it is not going to be installed
    Recommends: app-install-data-partner but it is not installable
    Recommends: apport-gtk but it is not installable
    Recommends: apport-hooks-elementary but it is not going to be installed
    Recommends: avahi-autoipd but it is not going to be installed
    Recommends: bluez-alsa but it is not installable
    Recommends: bluez-cups but it is not going to be installed
    Recommends: bluez-gstreamer but it is not installable
    Recommends: brltty but it is not going to be installed
    Recommends: capnet-assist but it is not going to be installed
    Recommends: cups but it is not going to be installed
    Recommends: cups-bsd but it is not going to be installed
    Recommends: elementary-default-settings but it is not going to be installed
    Recommends: elementary-os-prerelease but it is not going to be installed
    Recommends: evince but it is not going to be installed
    Recommends: file-roller but it is not going to be installed
    Recommends: fonts-elementary-core but it is not going to be installed
    Recommends: fonts-kacst-one but it is not going to be installed
    Recommends: fonts-khmeros-core but it is not installable
    Recommends: fonts-lao but it is not going to be installed
    Recommends: fonts-lklug-sinhala but it is not going to be installed
    Recommends: fonts-nanum but it is not going to be installed
    Recommends: fonts-sil-abyssinica but it is not going to be installed
    Recommends: fonts-sil-padauk but it is not going to be installed
    Recommends: fonts-takao-pgothic but it is not installable
    Recommends: fonts-thai-tlwg but it is not going to be installed
    Recommends: fonts-tibetan-machine but it is not going to be installed
    Recommends: gcalctool but it is not going to be installed
    Recommends: geary but it is not going to be installed
    Recommends: ginn but it is not installable
    Recommends: gnome-codec-install but it is not going to be installed
    Recommends: gnome-font-viewer but it is not going to be installed
    Recommends: gnome-orca but it is not going to be installed
    Recommends: gnome-power-manager but it is not going to be installed
    Recommends: gnome-screenshot but it is not going to be installed
    Recommends: gnome-session-bin but it is not going to be installed
    Recommends: gtksourceview-3.0-theme-solarized-elementary but it is not going to be installed
    Recommends: gvfs-bin but it is not going to be installed
    Recommends: hplip but it is not going to be installed
    Recommends: ibus but it is not going to be installed
    Recommends: ibus-gtk3 but it is not going to be installed
    Recommends: ibus-pinyin but it is not going to be installed
    Recommends: ibus-table but it is not going to be installed
    Recommends: im-config but it is not going to be installed
    Recommends: indicator-application but it is not installable
    Recommends: indicator-bluetooth but it is not installable
    Recommends: indicator-datetime but it is not installable
    Recommends: indicator-keyboard but it is not installable
    Recommends: indicator-power but it is not installable
    Recommends: indicator-session but it is not going to be installed
    Recommends: indicator-sound but it is not installable
    Recommends: kerneloops-daemon but it is not installable
    Recommends: language-selector-gnome but it is not installable
    Recommends: libgail-common but it is not going to be installed
    Recommends: libproxy1-plugin-gsettings but it is not going to be installed
    Recommends: libproxy1-plugin-networkmanager but it is not going to be installed
    Recommends: libwmf0.2-7-gtk but it is not installable
    Recommends: light-locker but it is not going to be installed
    Recommends: network-manager-pptp but it is not going to be installed
    Recommends: network-manager-pptp-gnome but it is not going to be installed
    Recommends: onboard but it is not installable
    Recommends: pantheon-greeter but it is not going to be installed
    Recommends: pcmciautils but it is not going to be installed
    Recommends: plymouth-theme-elementary but it is not going to be installed
    Recommends: plymouth-theme-elementary-text but it is not going to be installed
    Recommends: policykit-desktop-privileges but it is not installable
    Recommends: print-test-page-elementary but it is not going to be installed
    Recommends: printer-driver-c2esp but it is not going to be installed
    Recommends: printer-driver-foo2zjs but it is not going to be installed
    Recommends: printer-driver-min12xxw but it is not going to be installed
    Recommends: printer-driver-ptouch but it is not going to be installed
    Recommends: printer-driver-pxljr but it is not going to be installed
    Recommends: printer-driver-sag-gdi but it is not going to be installed
    Recommends: printer-driver-splix but it is not going to be installed
    Recommends: pulseaudio-module-bluetooth but it is not going to be installed
    Recommends: pulseaudio-module-gconf but it is not going to be installed
    Recommends: python3-aptdaemon.pkcompat but it is not going to be installed
    Recommends: simple-scan but it is not going to be installed
    Recommends: software-center but it is not installable
    Recommends: speech-dispatcher but it is not going to be installed
    Recommends: ssh-askpass-gnome but it is not going to be installed
    Recommends: switchboard but it is not going to be installed
    Recommends: switchboard-gnome-control-center-override but it is not going to be installed
    Recommends: switchboard-plug-about but it is not going to be installed
    Recommends: switchboard-plug-applications but it is not going to be installed
    Recommends: switchboard-plug-display but it is not going to be installed
    Recommends: switchboard-plug-gcc-bluetooth but it is not going to be installed
    Recommends: switchboard-plug-gcc-color but it is not going to be installed
    Recommends: switchboard-plug-gcc-date but it is not going to be installed
    Recommends: switchboard-plug-gcc-mouse but it is not going to be installed
    Recommends: switchboard-plug-gcc-network but it is not going to be installed
    Recommends: switchboard-plug-gcc-printer but it is not going to be installed
    Recommends: switchboard-plug-gcc-sound but it is not going to be installed
    Recommends: switchboard-plug-gcc-ua but it is not going to be installed
    Recommends: switchboard-plug-gcc-users but it is not going to be installed
    Recommends: switchboard-plug-gcc-wacom but it is not going to be installed
    Recommends: switchboard-plug-keyboard but it is not going to be installed
    Recommends: switchboard-plug-locale but it is not going to be installed
    Recommends: switchboard-plug-online-accounts but it is not going to be installed
    Recommends: switchboard-plug-pantheon-shell but it is not going to be installed
    Recommends: switchboard-plug-power but it is not going to be installed
    Recommends: switchboard-plug-security-privacy but it is not going to be installed
    Recommends: ttf-indic-fonts-core but it is not installable
    Recommends: ttf-punjabi-fonts but it is not installable
    Recommends: ttf-ubuntu-font-family but it is not installable
    Recommends: tumbler-plugins-extra but it is not going to be installed
    Recommends: update-manager but it is not installable
    Recommends: user-specific-alternatives but it is not going to be installed
    Recommends: whoopsie but it is not installable
    Recommends: xcursor-themes but it is not going to be installed
    Recommends: xdg-user-dirs-gtk but it is not going to be installed
    E: Unable to correct problems, you have held broken packages.
    root@buildmach:~/Desktop#
     
  11. Dragan

    Staff Member

    Joined:
    13.01.2012
    Messages:
    7,246
    Likes Received:
    4,817
    Location:
    jóhonaaʼéí
    Okruženje:
    XFCE
    Sistem:
    TRIOS
    Ok, stigoh do nekog polovičnog rezultata :)
    Uz mnogo žongliranja sa repoima, i nabadanja šta se kojim redom mora instalirati, "rešio" sam gomilu zavisnosti, i uspevam da pokrećem "sve", osim Pantheona :D

    Gala se pokreće preko xfce, i praktično sve ostale aplikacije...Plank, Maya kalendar, terminal, Scratch...nisam se ni udubljivao šta sve ima.

    Pošto je sve ovo jedna užasna budževina (Debian wheezy apgrejdovan prvo na testing, pa na sid, uz dodatak Triosa, + gomila razvojnih programa + sve zabibereno gomilom elementary ppa..) čudo da uopšte i ovoliko radi :D
    Nema, za sada, nikakvu upotrebnu vrednost, osim kao vežbanka za zaludne :)
    Sutra ću probati da podesim i X sesiju, da pokrenem i kompletan Pantheon..

    Kažu: "ako ne možeš da vidiš, nije se ni desilo.." pa evo i malo slikica :)

    SID1.png SID2.png SID3.png
    SID4.png SID5.png SID6.png
    -----------
    root@buildmach:~# uname -a
    Linux buildmach 3.16-1-amd64 #1 SMP Debian 3.16.2-3 (2014-09-13) x86_64 GNU/Linux
    root@buildmach:~#
    ----------------

    SID7.png
     
    gagiD likes this.
  12. Dragan

    Staff Member

    Joined:
    13.01.2012
    Messages:
    7,246
    Likes Received:
    4,817
    Location:
    jóhonaaʼéí
    Okruženje:
    XFCE
    Sistem:
    TRIOS
    UPDATE:
    Prilično je bezveze da pokušavam da uglavim u Debian ono što nisam isprobao u originalu :D
    LM, reših i to, skinuo sam Freya beta iso, i isprobavam ga u vboxu.

    Ono što mi strašno ide na živce je bahatost onih koji rade na tom eosu (valjda su to nasledili od tuntu tima..)..zar oni stvarno misle da će, u današnje vreme, svako odmah da instalira neki os "na metal"?

    Kada zanemarim tu glupost da isprobavam os u prozoru veličine razglednice, ostaje utisak:
    1) Instaler lepo radi..naravno, naš je i dalje brzinski šampion kada se poredi sa ovim :)
    2) dodao sam vbox GA, pa sada može udobnije da se radi :)
    3) ideja je, vezano za prethodno isprobavanje kako to radi na debianu, da uradim obrnuto...umesto da dodajem Pantheon u Debian, probaću da dodam Debian u Eos..zamenim glavne repoe (tuntu) na Debianove, počistim však tuntu paketa, pa da vidim šta ćemo dobiti :)

    FreyaEos1.png FreyaEos2.png FreyaEos3.png
    FreyaEos4.png FreyaEos5.png FreyaEos6.png
    FreyaEos7.png FreyaEos8.png FreyaEos9.png
     
    Lazar and m4m like this.
  13. marecare

    Premium Donator

    Joined:
    09.05.2014
    Messages:
    1,427
    Likes Received:
    1,008
    Okruženje:
    Cinnamon
    Sistem:
    Mint
    Instalirao sam juce EOS i podesio dosta stvari i sve radi odlicno. Jedna stvar me je izludjivala sve vreme a to je preosetljivost touchpad-a, cinilo mi se da samo stanem na neku ikonu i on pokrene aplikaciju (ponekad i 2, 3 puta). Ako nekom bude zatrebalo, naredba za resavanje ove situacije je:
    synclient PalmMinZ=5
     
  14. milansombor

    Korisnik

    Joined:
    11.11.2012
    Messages:
    324
    Likes Received:
    66
    Location:
    Сомбор
    Okruženje:
    KDE 4
    Sistem:
    Mint
    Инсталирао сам га, лепо изгледа, брз је, али је по мом укусу недоречен.
    Подсећа ме на дане када сам живео у незнању и користио виндозу, треба ти цела вечност да инсталираш све програме и доведеш га у функционално стање.
    Такође, неко је овде рекао да му је велика мана недостатак подешавања програма.
    Али, једног дана, ко зна ...

    Мој је закључак да је још незрео да би био примарни систем на рачунару.
     
    Collapse Signature Expand Signature
  15. iz0t0p

    Korisnik

    Joined:
    17.09.2014
    Messages:
    99
    Likes Received:
    34
    Location:
    /
    Sistem:
    Elementary
    verzija je 0.2
    sa druge strane, uz iole brz internet ranga 4mb/s ovoljno je sat da se dovuku neophodne stvari. ako ne znas sta zelis, ima na gomili blogova na netu sta kako...
    nije out of the box resenje, ali meni je primarni sistem vec jako jako dugo, i nemam nameru da ga menjam
    u kom smislu nedostatak podesavanja programa?
     
  16. milansombor

    Korisnik

    Joined:
    11.11.2012
    Messages:
    324
    Likes Received:
    66
    Location:
    Сомбор
    Okruženje:
    KDE 4
    Sistem:
    Mint
    Па ево, што ми тренутно пада на памет, е-маил клијент нема скоро никакве опције за подешавање налога, не можеш рецимо да подесиш да ти остави поруке на серверу како би могао да их преузмеш на примарни систем, па ако имаш неку важну комуникацију путем е-маила то може да буде доста незгодно
     
    Collapse Signature Expand Signature
  17. ubuntuser

    Korisnik

    Joined:
    07.04.2014
    Messages:
    878
    Likes Received:
    272
    Location:
    Kragujevac
    Okruženje:
    Cinnamon
    Sistem:
    Mint
    @milansombor Ipak mislim da to nema nikakve veze sa eOS-om, već sa E-mail klijentom...:D Instaliraš neki drugi E-mail klijent (Thunderbird npr.)...:D
     
    iz0t0p likes this.
  18. Filip

    Korisnik

    Joined:
    21.07.2012
    Messages:
    3,297
    Likes Received:
    1,600
    Location:
    Beograd
    Okruženje:
    XFCE
    Sistem:
    TRIOS
    Yep, Geary je Gnome aplikacija :) https://wiki.gnome.org/Apps/Geary
    Kako misliš da ostavi na serveru? Geary je IMAP-only klijent, u prevodu ništa se na serveru ne dira, samo ti markira poruke kao pročitane.
    Tj. sam ih ne briše/ne premešta... :look:
     
    Collapse Signature Expand Signature
  19. milansombor

    Korisnik

    Joined:
    11.11.2012
    Messages:
    324
    Likes Received:
    66
    Location:
    Сомбор
    Okruženje:
    KDE 4
    Sistem:
    Mint
    Па добро, не разумем баш разлику између ПОП3 и ИМАП протокола, али добро, све у свему мени и даље делује прилично недоречен, доста додатних апликација мора да е инсталира да би био функционалан као нпр. минт.
     
    Collapse Signature Expand Signature
  20. ubuntuser

    Korisnik

    Joined:
    07.04.2014
    Messages:
    878
    Likes Received:
    272
    Location:
    Kragujevac
    Okruženje:
    Cinnamon
    Sistem:
    Mint
    @milansombor POP3 protokol je takav protokol za Email client kod koga se svi mailovi sa naloga (nekimail@gmail.com npr.) čuvaju i lokalno u računaru... Npr. u Linux-u dobiješ folder u okviru /home particije i svi mailovi sa naloga se tu čuvaju... Kod IMAP protokola u okviru Email client-a mailovi se ne čuvaju lokalno (na računaru) već samo na nalogu, odnosno na serveru (nekimail@gmail.com)... Bar ja tako shvatam razliku između ta dva protokola...:D