Dobrodošli na FOSS Srbija

Free and Opensource Srbija je skup entuzijasta i ljubitelja slobodnog i otvorenog koda. Cilj nam je okupiti sve istomišljenike na jednom mestu i stvoriti najveći globalni OpenSource projekat u Srbiji i šire!

  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

LinuxMint Linux Mint 17 Qiana

Discussion in 'Debian, LinuxMint, Ubuntu' started by Filip, 22.03.2014.

  1. marecare

    Premium Donator

    Joined:
    09.05.2014
    Messages:
    1,427
    Likes Received:
    1,008
    Okruženje:
    Cinnamon
    Sistem:
    Mint
    evo sta kaze inxi:

    marko@marko-mint17 ~ $ inxi -Gxxx
    Graphics: Card: Intel 3rd Gen Core processor Graphics Controller bus-ID: 00:02.0
    X.Org: 1.15.1 drivers: (unloaded: fbdev,vesa) FAILED: nouveau,intel Resolution: 1366x768@60.1hz
    GLX Renderer: Mesa DRI Intel Ivybridge Mobile GLX Version: 3.0 Mesa 10.1.0 Direct Rendering: Yes
    marko@marko-mint17 ~ $
     
  2. Mikulino

    Korisnik

    Joined:
    24.12.2012
    Messages:
    308
    Likes Received:
    158
    Location:
    Ispod krova, pored razbijenog Windowsa
    Okruženje:
    Mate
    Sistem:
    Mint
    pokreni menadžer upravljača ili u
    terminalu

    driver-manager
    i daj screanshot da vidimo da li mint vidi nvidia grafiku
     
    Collapse Signature Expand Signature
  3. marecare

    Premium Donator

    Joined:
    09.05.2014
    Messages:
    1,427
    Likes Received:
    1,008
    Okruženje:
    Cinnamon
    Sistem:
    Mint
    Rekao bih da vidi
     

    Attached Files:

  4. Mikulino

    Korisnik

    Joined:
    24.12.2012
    Messages:
    308
    Likes Received:
    158
    Location:
    Ispod krova, pored razbijenog Windowsa
    Okruženje:
    Mate
    Sistem:
    Mint
    Collapse Signature Expand Signature
  5. marecare

    Premium Donator

    Joined:
    09.05.2014
    Messages:
    1,427
    Likes Received:
    1,008
    Okruženje:
    Cinnamon
    Sistem:
    Mint
    Jel moze neko da mi da link za instaliranje i podesavanje Bamblebee-a?! Trazio sam po netu ali toliko razlicitih primera ima da sam se skroz pogubio.
     
  6. Filip

    Korisnik

    Joined:
    21.07.2012
    Messages:
    3,297
    Likes Received:
    1,600
    Location:
    Beograd
    Okruženje:
    XFCE
    Sistem:
    TRIOS
    ^ http://forums.linuxmint.com/viewtopic.php?f=59&t=168957#p870296

    [hr]

    Cimet 2.4 beta :)

    http://segfault.linuxmint.com/2014/11/cinnamon-2-4/
    http://blog.linuxmint.com/?p=2698
    Biće default u 17.1, kao i u LMDE2.
    U međuvremenu može se probati na 17-ici, uključivanjem Romeo repoa ( uputstvo na Mint blogu, drugi link^ ). :)
     
    Collapse Signature Expand Signature
    autsajder and Lazar like this.
  7. marecare

    Premium Donator

    Joined:
    09.05.2014
    Messages:
    1,427
    Likes Received:
    1,008
    Okruženje:
    Cinnamon
    Sistem:
    Mint
    Cofi, evo odradio sam ovaj prvi deo ali mi posle instalacije prijavljuje ERROR (5. red od pozadi, obelezio sam crvenim):

    marko@marko-mint17 ~ $ sudo apt-get install bumblebee bumblebee-nvidia primus nvidia-331
    [sudo] password for marko:
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    The following packages were automatically installed and are no longer required:
    ant ant-optional antlr3 aspectj bsh javahelp2 junit junit-doc junit4
    junit4-doc libantlr-java libapr1 libaprutil1 libasm3-java libaspectj-java
    libaudclient2 libbeansbinding-java libbetter-appframework-java
    libbindex-java libbsh-java libbytelist-java libcglib-java
    libcommons-codec-java libcommons-net1-java libcompfaceg1 libeasymock-java
    libfelix-framework-java libfelix-main-java libflute-java libfreemarker-java
    libgee2 libgeronimo-jpa-2.0-spec-java libgeronimo-osgi-support-java
    libgnome-desktop-2-17 libgnome-keyring1.0-cil libgnomedesktop2.20-cil
    libhamcrest-java libid3tag0 libimlib2 libini4j-java libjcodings-java
    libjemmy2-java libjetty-java libjline-java libjna-java libjoda-time-java
    libjsch-java libjvyamlb-java libjzlib-java liblucene2-java
    libmono-sqlite4.0-cil
    libmono-system-runtime-serialization-formatters-soap4.0-cil
    libmono-system-web-applicationservices4.0-cil
    libmono-system-web-services4.0-cil libmono-system-web4.0-cil
    libmono-web4.0-cil libnb-absolutelayout-java libnb-javaparser-java
    libnetx-java libonig2 liboro-java libosgi-compendium-java libosgi-core-java
    libosgi-foundation-ee-java libpisock9 librsvg2-2.18-cil libsac-java
    libsequence-library-java libserf-1-1 libservlet2.5-java libslf4j-java
    libsqljet-java libstringtemplate-java libsvn-java libsvn1
    libsvnclientadapter-java libsvnkit-java libswing-layout-java libswingx1-java
    libtrilead-ssh2-java libwnck2.20-cil libxerces2-java
    libxml-commons-external-java libxml-commons-resolver1.1-java libxmmsclient6
    realpath totem-common
    Use 'apt-get autoremove' to remove them.
    The following extra packages will be installed:
    bbswitch-dkms lib32gcc1 primus-libs socat
    Suggested packages:
    nvidia-331-uvm
    Recommended packages:
    nvidia-settings libcuda1-331 nvidia-libopencl1-331 nvidia-opencl-icd-331
    primus-libs-ia32
    The following NEW packages will be installed:
    bbswitch-dkms bumblebee bumblebee-nvidia lib32gcc1 nvidia-331 primus
    primus-libs socat
    0 upgraded, 8 newly installed, 0 to remove and 27 not upgraded.
    Need to get 36.9 MB of archives.
    After this operation, 183 MB of additional disk space will be used.
    Do you want to continue? [Y/n] y
    Get:1 http://archive.ubuntu.com/ubuntu/ trusty-updates/main lib32gcc1 amd64 1:4.9.1-0ubuntu1 [47.6 kB]
    Get:2 http://archive.ubuntu.com/ubuntu/ trusty-updates/restricted nvidia-331 amd64 331.38-0ubuntu7.1 [36.4 MB]
    Get:3 http://archive.ubuntu.com/ubuntu/ trusty/main bbswitch-dkms amd64 0.7-2ubuntu1 [10.9 kB]
    Get:4 http://archive.ubuntu.com/ubuntu/ trusty/universe bumblebee amd64 3.2.1-5 [45.0 kB]
    Get:5 http://archive.ubuntu.com/ubuntu/ trusty/universe bumblebee-nvidia amd64 3.2.1-5 [3,156 B]
    Get:6 http://archive.ubuntu.com/ubuntu/ trusty/universe socat amd64 1.7.2.3-1 [302 kB]
    Get:7 http://archive.ubuntu.com/ubuntu/ trusty/universe primus-libs amd64 0~20131127-2 [49.0 kB]
    Get:8 http://archive.ubuntu.com/ubuntu/ trusty/universe primus amd64 0~20131127-2 [9,548 B]
    Fetched 36.9 MB in 1min 3s (579 kB/s)
    Selecting previously unselected package lib32gcc1.
    (Reading database ... 258153 files and directories currently installed.)
    Preparing to unpack .../lib32gcc1_1%3a4.9.1-0ubuntu1_amd64.deb ...
    Unpacking lib32gcc1 (1:4.9.1-0ubuntu1) ...
    Selecting previously unselected package nvidia-331.
    Preparing to unpack .../nvidia-331_331.38-0ubuntu7.1_amd64.deb ...
    Unpacking nvidia-331 (331.38-0ubuntu7.1) ...
    Selecting previously unselected package bbswitch-dkms.
    Preparing to unpack .../bbswitch-dkms_0.7-2ubuntu1_amd64.deb ...
    Unpacking bbswitch-dkms (0.7-2ubuntu1) ...
    Selecting previously unselected package bumblebee.
    Preparing to unpack .../bumblebee_3.2.1-5_amd64.deb ...
    Unpacking bumblebee (3.2.1-5) ...
    Selecting previously unselected package bumblebee-nvidia.
    Preparing to unpack .../bumblebee-nvidia_3.2.1-5_amd64.deb ...
    Unpacking bumblebee-nvidia (3.2.1-5) ...
    Selecting previously unselected package socat.
    Preparing to unpack .../socat_1.7.2.3-1_amd64.deb ...
    Unpacking socat (1.7.2.3-1) ...
    Selecting previously unselected package primus-libs:amd64.
    Preparing to unpack .../primus-libs_0~20131127-2_amd64.deb ...
    Unpacking primus-libs:amd64 (0~20131127-2) ...
    Selecting previously unselected package primus.
    Preparing to unpack .../primus_0~20131127-2_amd64.deb ...
    Unpacking primus (0~20131127-2) ...
    Processing triggers for ureadahead (0.100.0-16) ...
    ureadahead will be reprofiled on next reboot
    Processing triggers for man-db (2.6.7.1-1ubuntu1) ...
    Processing triggers for initramfs-tools (0.103ubuntu4.2) ...
    update-initramfs: Generating /boot/initrd.img-3.13.0-37-generic
    Warning: No support for locale: en_US.utf8
    Processing triggers for doc-base (0.10.5) ...
    Processing 1 added doc-base file...
    Registering documents with scrollkeeper...
    Setting up lib32gcc1 (1:4.9.1-0ubuntu1) ...
    Setting up nvidia-331 (331.38-0ubuntu7.1) ...
    update-alternatives: using /usr/lib/nvidia-331/ld.so.conf to provide /etc/ld.so.conf.d/x86_64-linux-gnu_GL.conf (x86_64-linux-gnu_gl_conf) in auto mode
    update-alternatives: using /usr/lib/nvidia-331/alt_ld.so.conf to provide /etc/ld.so.conf.d/i386-linux-gnu_GL.conf (i386-linux-gnu_gl_conf) in auto mode
    update-alternatives: using /usr/share/nvidia-331/glamor.conf to provide /usr/share/X11/xorg.conf.d/glamoregl.conf (glamor_conf) in auto mode
    update-initramfs: deferring update (trigger activated)
    INFO:Enable nvidia-331
    DEBUG:parsing /usr/share/ubuntu-drivers-common/quirks/lenovo_thinkpad
    DEBUG:parsing /usr/share/ubuntu-drivers-common/quirks/put_your_quirks_here
    DEBUG:parsing /usr/share/ubuntu-drivers-common/quirks/dell_latitude
    Adding system user `nvidia-persistenced' (UID 115) ...
    Adding new group `nvidia-persistenced' (GID 125) ...
    Adding new user `nvidia-persistenced' (UID 115) with group `nvidia-persistenced' ...
    Not creating home directory `/'.
    Loading new nvidia-331-331.38 DKMS files...
    First Installation: checking all kernels...
    Building only for 3.13.0-37-generic
    Building for architecture x86_64
    Building initial module for 3.13.0-37-generic
    Done.

    nvidia_331:
    Running module version sanity check.
    - Original module
    - No original module exists within this kernel
    - Installation
    - Installing to /lib/modules/3.13.0-37-generic/kernel/drivers/char/drm/

    depmod.......

    DKMS: install completed.
    Setting up bbswitch-dkms (0.7-2ubuntu1) ...
    Loading new bbswitch-0.7 DKMS files...
    First Installation: checking all kernels...
    Building only for 3.13.0-37-generic
    Building initial module for 3.13.0-37-generic
    Done.

    bbswitch:
    Running module version sanity check.
    - Original module
    - No original module exists within this kernel
    - Installation
    - Installing to /lib/modules/3.13.0-37-generic/kernel/drivers/acpi/

    depmod....

    DKMS: install completed.
    Setting up bumblebee (3.2.1-5) ...
    Adding members from group(s) 'adm sudo admin' to 'bumblebee':
    marko syslog
    Adding user marko to group bumblebee
    Adding user syslog to group bumblebee
    Selecting 02:00:0 as discrete nvidia card. If this is incorrect,
    edit the BusID line in /etc/bumblebee/xorg.conf.nouveau .
    bumblebeed start/running, process 15026
    Setting up socat (1.7.2.3-1) ...
    Setting up primus-libs:amd64 (0~20131127-2) ...
    Processing triggers for initramfs-tools (0.103ubuntu4.2) ...
    update-initramfs: Generating /boot/initrd.img-3.13.0-37-generic
    Warning: No support for locale: en_US.utf8
    Processing triggers for ureadahead (0.100.0-16) ...
    Setting up primus (0~20131127-2) ...
    Setting up bumblebee-nvidia (3.2.1-5) ...
    update-alternatives: using /usr/lib/x86_64-linux-gnu/mesa/ld.so.conf to provide /etc/ld.so.conf.d/x86_64-linux-gnu_GL.conf (x86_64-linux-gnu_gl_conf) in manual mode
    update-alternatives: using /usr/lib/i386-linux-gnu/mesa/ld.so.conf to provide /etc/ld.so.conf.d/i386-linux-gnu_GL.conf (i386-linux-gnu_gl_conf) in manual mode
    Selecting 02:00:0 as discrete nvidia card. If this is incorrect,
    edit the BusID line in /etc/bumblebee/xorg.conf.nvidia
    rmmod: ERROR: Module nouveau is in use
    bumblebeed stop/waiting
    bumblebeed start/running, process 23938
    Processing triggers for libc-bin (2.19-0ubuntu6.3) ...
    marko@marko-mint17 ~ $
     
  8. Filip

    Korisnik

    Joined:
    21.07.2012
    Messages:
    3,297
    Likes Received:
    1,600
    Location:
    Beograd
    Okruženje:
    XFCE
    Sistem:
    TRIOS
    Sve je ok, samo trebaš da restartuješ mahinu.
    Ovo praktično govori da je potreban restart (da bi nV drajver "preuzeo" kontrolu) , pošto su nouveau i nvidia kernel moduli u konfliktu. Samo jedan može biti aktivan, a ne mogu se unload-ovati "na živo" ( rmmod je komanda za unload modula ).

    Tako da, za sve važi, ne cimajte se kad viditi ovakvu ili sličnu poruku, sve je ok, samo je potreban restart! :wink:
     
    Collapse Signature Expand Signature
    marecare likes this.
  9. marecare

    Premium Donator

    Joined:
    09.05.2014
    Messages:
    1,427
    Likes Received:
    1,008
    Okruženje:
    Cinnamon
    Sistem:
    Mint
    Restartovan komp. :)

    E sada jos 2 stvari:
    1. Kako da testiram da li radi Bumblebee, tj da li prebacuje na Nvidia-u?!
    2. Da li je potrebno, pre nego sto pokrenem neku zahtevnu aplikaciju ili igricu, pokrenuti manuelno Nvidia-u

    Mozda bi i ova pitanja trebala da idu obrnutim redom :)

    I naravno VELIKO TI HVALA :)
     
  10. Filip

    Korisnik

    Joined:
    21.07.2012
    Messages:
    3,297
    Likes Received:
    1,600
    Location:
    Beograd
    Okruženje:
    XFCE
    Sistem:
    TRIOS
    1. inxi -Gxxx
    Pa ćeš videti u ispisu koji je drajver u upotrebi :) Primer:

    [filip@trios][~]$ inxi -Gxxx
    Graphics: Card: NVIDIA G94 [GeForce 9600 GT] bus-ID: 01:00.0 chip-ID: 10de:0622
    Display Server: X.Org 1.16.1 --->>>> driver: nvidia
     
    Collapse Signature Expand Signature
  11. marecare

    Premium Donator

    Joined:
    09.05.2014
    Messages:
    1,427
    Likes Received:
    1,008
    Okruženje:
    Cinnamon
    Sistem:
    Mint
    1. I dalje je kao i pre instalacije:

    marko@marko-mint17 ~ $ inxi -Gxxx
    Graphics: Card: Intel 3rd Gen Core processor Graphics Controller bus-ID: 00:02.0
    X.Org: 1.15.1 drivers: intel (unloaded: fbdev,vesa) Resolution: 1366x768@60.1hz
    GLX Renderer: Mesa DRI Intel Ivybridge Mobile GLX Version: 3.0 Mesa 10.1.3 Direct Rendering: Yes
    marko@marko-mint17 ~ $

    2. E pa da, znam da sam i ja negde to procitao
     
  12. Filip

    Korisnik

    Joined:
    21.07.2012
    Messages:
    3,297
    Likes Received:
    1,600
    Location:
    Beograd
    Okruženje:
    XFCE
    Sistem:
    TRIOS
    Collapse Signature Expand Signature