Dobrodošli na FOSS Srbija

Free and Opensource Srbija je skup entuzijasta i ljubitelja slobodnog i otvorenog koda. Cilj nam je okupiti sve istomišljenike na jednom mestu i stvoriti najveći globalni OpenSource projekat u Srbiji i šire!

  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

LinuxMint Mint i 5.1

Discussion in 'Debian, LinuxMint, Ubuntu' started by Anak1n1, 27.11.2013.

  1. Anak1n1

    Korisnik

    Joined:
    27.11.2013
    Messages:
    8
    Likes Received:
    0
    Sistem:
    Mint
    Konfigurisao sam zvucnike 5.1 i svi rade. Medjutim kada pustim muziku moram da udjem u sound setting pa da prebacim na 4.1 i onda prorade svi zvucnici, pa posle toga vratim na 5.1 (U pitanju je banshee player, a svi zvucnici na testu daju zvuk). Malo je to zamorno, postoji li neko elegantnije resenje, ili je to jednostavno tako?
     
  2. Commander

    Staff Member

    Joined:
    13.01.2012
    Messages:
    9,736
    Likes Received:
    4,762
    Okruženje:
    Gnome 3
    Sistem:
    Debian
    Ja imam 2.1 pa to obično radi. Souround već ne znam kako ide, a da li si pokušao sa nekim drugim plejerom ili je problem do zvuka generalno!?

    Jel imaš integrisanu zvučnu ili neku PCIx? Postoji određen broj problema kada kačiš 5.1 na integrisanu.

    P.S. Dobrodošao na forum ;)
     
    Collapse Signature Expand Signature
  3. Anak1n1

    Korisnik

    Joined:
    27.11.2013
    Messages:
    8
    Likes Received:
    0
    Sistem:
    Mint
    Hvala
    Integrisana zvucna je u pitanju. Bilo koji player se ponasa isto posto ako sam to dobro shvatio svi se oslanjaju na gstreamer. I kad prebacim na sledecu pesmu odmah gubim woofer levi zadnji i desni zadnji. Opet prebacim na 4.1 vratim na 5.1 i radi, stvarno nervira. Na fedori je radilo bez dodatnih podesavanja.
     
  4. Commander

    Staff Member

    Joined:
    13.01.2012
    Messages:
    9,736
    Likes Received:
    4,762
    Okruženje:
    Gnome 3
    Sistem:
    Debian
    Onda je problem do nekog drajvera, očigledno do gstreamer-a. ako kažeš da ti je u Fedori radilo onda možda da instaliraš najnoviji gstreamer plugin na Mintu obzirom da je mint stabilna distribucija dok je fedora RR i uvek ima najnoviji software.

    Kažem ti nemam 5.1 pa ne znam kako idu podešavanja za njega, moguće da ti se javi @21 da ti preporuči neki plugin iz Debiana ili neko sa sličnim problemom ko je imao 5.1 ozvučenje.
     
    Collapse Signature Expand Signature
  5. darko

    Korisnik

    Joined:
    24.09.2012
    Messages:
    204
    Likes Received:
    189
    Okruženje:
    KDE 5
    Sistem:
    OpenSuse
    @Anak1n Jesi li konfigurisao /etc/pulse/daemon.conf ?
    Ovo su podešavanja is mog /etc/pulse/daemon.conf-a i rade na većini integrisanih i na PCI zvučnim karticama:

    # This file is part of PulseAudio.
    #
    # PulseAudio is free software; you can redistribute it and/or modify
    # it under the terms of the GNU Lesser General Public License as published by
    # the Free Software Foundation; either version 2 of the License, or
    # (at your option) any later version.
    #
    # PulseAudio is distributed in the hope that it will be useful, but
    # WITHOUT ANY WARRANTY; without even the implied warranty of
    # MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
    # General Public License for more details.
    #
    # You should have received a copy of the GNU Lesser General Public License
    # along with PulseAudio; if not, write to the Free Software
    # Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307
    # USA.

    ## Configuration file for the PulseAudio daemon. See pulse-daemon.conf(5) for
    ## more information. Default values are commented out. Use either ; or # for
    ## commenting.

    ; daemonize = no
    ; fail = yes
    ; allow-module-loading = yes
    ; allow-exit = yes
    ; use-pid-file = yes
    ; system-instance = no
    ; local-server-type = user
    ; enable-shm = yes
    ; shm-size-bytes = 0 # setting this 0 will use the system-default, usually 64 MiB
    ; lock-memory = no
    ; cpu-limit = no

    ; high-priority = yes
    ; nice-level = -11

    ; realtime-scheduling = yes
    ; realtime-priority = 5

    ; exit-idle-time = 20
    ; scache-idle-time = 20

    ; dl-search-path = (depends on architecture)

    ; load-default-script-file = yes
    ; default-script-file = /etc/pulse/default.pa

    ; log-target = auto
    ; log-level = notice
    ; log-meta = no
    ; log-time = no
    ; log-backtrace = 0

    resample-method = speex-float-1
    ; enable-remixing = yes
    enable-lfe-remixing = yes

    flat-volumes = no

    ; rlimit-fsize = -1
    ; rlimit-data = -1
    ; rlimit-stack = -1
    ; rlimit-core = -1
    ; rlimit-as = -1
    ; rlimit-rss = -1
    ; rlimit-nproc = -1
    ; rlimit-nofile = 256
    ; rlimit-memlock = -1
    ; rlimit-locks = -1
    ; rlimit-sigpending = -1
    ; rlimit-msgqueue = -1
    ; rlimit-nice = 31
    ; rlimit-rtprio = 9
    ; rlimit-rttime = 1000000

    ; default-sample-format = s16le
    default-sample-rate = 48000
    default-sample-channels = 6
    default-channel-map = front-left,front-right,rear-left,rear-right,front-center,lfe

    default-fragments = 8
    default-fragment-size-msec = 10

    ; enable-deferred-volume = yes
    deferred-volume-safety-margin-usec = 1
    ; deferred-volume-extra-delay-usec = 0
     
    Anak1n1 likes this.
  6. Anak1n1

    Korisnik

    Joined:
    27.11.2013
    Messages:
    8
    Likes Received:
    0
    Sistem:
    Mint
    Jesam nije problem u tome. Vidi on sve zvucnike u testu rade, ali kad pustim muziku rade samo dva. Prebacim na 4.1 i odma prorade i onda vratim na 5.1 i onda cujem zvuk sa svih zvucnika.
    Promenio sam i:

    default-channel-map = front-left,front-right


    Ali nema efekta, posel restarta pulsaduio.
    Code:
    ; daemonize = no
    ; fail = yes
    ; allow-module-loading = yes
    ; allow-exit = yes
    ; use-pid-file = yes
    ; system-instance = no
    ; local-server-type = user
    ; enable-shm = yes
    ; shm-size-bytes = 0 # setting this 0 will use the system-default, usually 64 MiB
    ; lock-memory = no
    ; cpu-limit = no
    
    ; high-priority = yes
    ; nice-level = -11
    
    ; realtime-scheduling = yes
    ; realtime-priority = 5
    
    ; exit-idle-time = 20
    ; scache-idle-time = 20
    
    ; dl-search-path = (depends on architecture)
    
    ; load-default-script-file = yes
    ; default-script-file = /etc/pulse/default.pa
    
    ; log-target = auto
    ; log-level = notice
    ; log-meta = no
    ; log-time = no
    ; log-backtrace = 0
    
    resample-method = speex-float-1
    ; enable-remixing = yes
    ; enable-lfe-remixing = no
    
    flat-volumes = no
    
    ; rlimit-fsize = -1
    ; rlimit-data = -1
    ; rlimit-stack = -1
    ; rlimit-core = -1
    ; rlimit-as = -1
    ; rlimit-rss = -1
    ; rlimit-nproc = -1
    ; rlimit-nofile = 256
    ; rlimit-memlock = -1
    ; rlimit-locks = -1
    ; rlimit-sigpending = -1
    ; rlimit-msgqueue = -1
    ; rlimit-nice = 31
    ; rlimit-rtprio = 9
    ; rlimit-rttime = 1000000
    
    ; default-sample-format = s16le
    ; default-sample-rate = 44100
    ; alternate-sample-rate = 48000
    ; default-sample-channels = 6
    ; default-channel-map = front-left,front-right
    
    default-fragments = 8
    default-fragment-size-msec = 10
    
    ; enable-deferred-volume = yes
    deferred-volume-safety-margin-usec = 1
    ; deferred-volume-extra-delay-usec = 0
    
     
  7. becho2150

    Korisnik

    Joined:
    28.08.2012
    Messages:
    43
    Likes Received:
    7
    Sistem:
    Debian
  8. Anak1n1

    Korisnik

    Joined:
    27.11.2013
    Messages:
    8
    Likes Received:
    0
    Sistem:
    Mint
    Blize sam resenju. Kod mene za subwoofer ne stoji Low Freq. E nego subwoofer
     
  9. darko

    Korisnik

    Joined:
    24.09.2012
    Messages:
    204
    Likes Received:
    189
    Okruženje:
    KDE 5
    Sistem:
    OpenSuse
    Nisi lepo konfigurisao:
    resample-method = speex-float-1
    ; enable-remixing = yes
    ; enable-lfe-remixing = no

    treba da bude:

    resample-method = speex-float-1
    ; enable-remixing = yes
    enable-lfe-remixing = yes

    I

    ; default-sample-format = s16le
    ; default-sample-rate = 44100
    ; alternate-sample-rate = 48000
    ; default-sample-channels = 6
    ; default-channel-map = front-left,front-right

    treba da bude:

    ; default-sample-format = s16le
    default-sample-rate = 44100 ili 48000
    ; alternate-sample-rate = 48000
    default-sample-channels = 6
    default-channel-map = front-left,front-right,rear-left,rear-right,front-center,lfe

    Džaba menjaš sva podešavanja ako ne skloniš ; ispred .
     
  10. Anak1n1

    Korisnik

    Joined:
    27.11.2013
    Messages:
    8
    Likes Received:
    0
    Sistem:
    Mint
    to sam uradio, a ovo je trebalo samo dodati:

    default-channel-map = front-left,front-right,rear-left,rear-right,front-center,subwoofer

    umeste lfe

    i

    enable-lfe-remixing = yes
    obavezno
    Hvala reseno :D
     
  11. Filip

    Korisnik

    Joined:
    21.07.2012
    Messages:
    3,297
    Likes Received:
    1,600
    Location:
    Beograd
    Okruženje:
    XFCE
    Sistem:
    TRIOS
    Ja samo opicim 6 channel u alsamixer-u i rade svi zvucnici u svim muzickim player-ima, Pulse zaobilazim u sirokom luku... :D
    View attachment 2210
     
    Collapse Signature Expand Signature
    dvajedan and pavik like this.
  12. darko

    Korisnik

    Joined:
    24.09.2012
    Messages:
    204
    Likes Received:
    189
    Okruženje:
    KDE 5
    Sistem:
    OpenSuse
    @Ćofi Što da bude lako, kad može komplikovano,nema lakih poena itd... ::)
     
    Filip likes this.
  13. Filip

    Korisnik

    Joined:
    21.07.2012
    Messages:
    3,297
    Likes Received:
    1,600
    Location:
    Beograd
    Okruženje:
    XFCE
    Sistem:
    TRIOS
    Pa to, al' zasto tako na linuksu...? :sarcastic: :D
    'Bem ti ja sound server na kom ne mozes na jedan klik misem/tastaturom ili jednom komandom da ukljucis 5.1 i da pritom radi kako treba, nego k'o manijak kroz .conf fajlove i to ako ubodes/znas... :connie_pumpkinsmile:
    User friendliness at it's best... :sarcastic:
     
    Collapse Signature Expand Signature
    darko likes this.
  14. dvajedan

    Korisnik

    Joined:
    17.06.2012
    Messages:
    3,442
    Likes Received:
    575
    Takođe :D. Priča se da je stabilna pulseta, but not for me :connie_lemon: .
     
  15. Filip

    Korisnik

    Joined:
    21.07.2012
    Messages:
    3,297
    Likes Received:
    1,600
    Location:
    Beograd
    Okruženje:
    XFCE
    Sistem:
    TRIOS
    Yep, stabilno za*ebava... :sarcastic:
     
    Collapse Signature Expand Signature
    darko likes this.
  16. darko

    Korisnik

    Joined:
    24.09.2012
    Messages:
    204
    Likes Received:
    189
    Okruženje:
    KDE 5
    Sistem:
    OpenSuse
    Manje zajebava od nvidie kepler serije
    bar je u tome stabilan :)
     
  17. Filip

    Korisnik

    Joined:
    21.07.2012
    Messages:
    3,297
    Likes Received:
    1,600
    Location:
    Beograd
    Okruženje:
    XFCE
    Sistem:
    TRIOS
    Sto? Ja nesto nisam cuo/citao da je kepler problematican na linuksu... Doduse mozda nisam u toku ( G94b 9600gt rocks my boat :D )... :connie_pumpkinsmile:
    @[member='Commander'] cini mi se ima GTX 660 i koliko znam nije se zalio na drajvere. :) Cekamo da potvrdi.
    No da ne idemo u off, ako ima neki problem, svakako otvaraj temu da resavamo! :chiffa:
     
    Collapse Signature Expand Signature
  18. dvajedan

    Korisnik

    Joined:
    17.06.2012
    Messages:
    3,442
    Likes Received:
    575
    Možda ima tearing :D.

    https://devtalk.nvidia.com/default/topic/543305/linux/screen-video-tearing-gtx-6xx-7xx-titan-kepler-in-almost-all-applications-including-the-desktop/

    Drugi su drajveri i za nvidia kepler i za amd gcn u odnosu na pređašnje generacije, jer ti čipovi više i nemaju 2D endžine naravno da treba da se piše i drugi drajver sa drugom akceleracijom, itd. ;). Tako da ne zeza Kepler niti GCN nego je to tako :D.

    https://devtalk.nvidia.com/default/topic/602831/unrecognized-flatpanelproperties-property-quot-scaling-quot-/?offset=12#3941192
     
  19. Anak1n1

    Korisnik

    Joined:
    27.11.2013
    Messages:
    8
    Likes Received:
    0
    Sistem:
    Mint
    Prvo sam alsamixer podesio, ali kada to nije urodilo plodom morao sam da se okrenem ka pulseaudio. Sve u svemu reseno :)
    Moram da dodam *bes linux ako ne cackas conf fajlove.
    Inace izbor prve distribucije bio i ostao slack jos od 2000 i neke :D
    Sad se nema toliko vremena za cackanje treba mi samo nesto sto ce stabilno da radi.
     
  20. Filip

    Korisnik

    Joined:
    21.07.2012
    Messages:
    3,297
    Likes Received:
    1,600
    Location:
    Beograd
    Okruženje:
    XFCE
    Sistem:
    TRIOS
    *ebes cackanje ako ti muzika ne radi :biggrin:
    Slazem se sa tobom, ali ipak je banalno, slozices se, to sto moras da (malo vise) cackas conf fajlove da bi upalio 5.1 zvuk, anno 2013. I to na pulseaudio koji je "unapredjena" ALSA... :)
     
    Collapse Signature Expand Signature
    Anak1n1 likes this.