Dobrodošli na FOSS Srbija

Free and Opensource Srbija je skup entuzijasta i ljubitelja slobodnog i otvorenog koda. Cilj nam je okupiti sve istomišljenike na jednom mestu i stvoriti najveći globalni OpenSource projekat u Srbiji i šire!

  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

LinuxMint ruzan font iznenada

Discussion in 'Debian, LinuxMint, Ubuntu' started by 0n3tw0, 14.06.2013.

  1. dvajedan

    Korisnik

    Joined:
    17.06.2012
    Messages:
    3,442
    Likes Received:
    575
    I naravno Džej :connie_pumpkinsmile:

    Code:
    sudo apt-get build-dep cairo:i386
    
    Kad budeš imao sve build zavisnoti (ali i i386 jelte) neće ti izlaziti ta greška :1: .
     
  2. 0n3tw0

    Korisnik

    Joined:
    06.02.2013
    Messages:
    413
    Likes Received:
    61
    Location:
    /
    Okruženje:
    XFCE
    Sistem:
    TRIOS
    @dvajedan, refresh-uj strane, imam duplo pitanje, tj pre ovog tvog poslednjeg sam ponovio pitanje na predhodnoj strani. ne znam sta da radim sa tim? da otkazem ili nastavim?
     
  3. dvajedan

    Korisnik

    Joined:
    17.06.2012
    Messages:
    3,442
    Likes Received:
    575
    Otkažeš jašta, nema tu ništa na silu, prvo zavisnoti doinstaliraj za i386 pak onda dalje :hi: .

    http://forum.opensource-srbija.org/topic/1954-ruzan-font-iznenada/page__st__60#entry31022
    http://forum.opensource-srbija.org/topic/1954-ruzan-font-iznenada/page__st__60#entry31026
    http://forum.opensource-srbija.org/topic/1954-ruzan-font-iznenada/page__st__80#entry31028
     
  4. 0n3tw0

    Korisnik

    Joined:
    06.02.2013
    Messages:
    413
    Likes Received:
    61
    Location:
    /
    Okruženje:
    XFCE
    Sistem:
    TRIOS
    jel ovo normalno ili ne:

    Code:
    nikola@nkl ~/novilab/cairo-1.12.14 $ sudo apt-get install build-essential:i386
    [sudo] password for nikola: 
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    You might want to run 'apt-get -f install' to correct these:
    The following packages have unmet dependencies:
    build-essential : Conflicts: build-essential:i386 but 11.6ubuntu4 is to be installed
    build-essential:i386 : Depends: libc6-dev:i386 but it is not going to be installed or
    libc-dev:i386
    Depends: gcc:i386 (>= 4:4.4.3) but it is not going to be installed
    Depends: g++:i386 (>= 4:4.4.3) but it is not going to be installed
    Depends: make:i386 but it is not going to be installed
    Conflicts: build-essential but 11.6ubuntu4 is to be installed
    libcairo2 : Breaks: libcairo2:i386 (!= 1.12.14-0ubuntu1nikola2) but 1.12.14-0ubuntu1 is to be installed
    libcairo2:i386 : Breaks: libcairo2 (!= 1.12.14-0ubuntu1) but 1.12.14-0ubuntu1nikola2 is to be installed
    E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
     
  5. dvajedan

    Korisnik

    Joined:
    17.06.2012
    Messages:
    3,442
    Likes Received:
    575
    Ma sad si ga zeznuo sa ona dva tvoja cairo paketa za koja fale i386 varijante vidiš to na kraju, reinstaliraj sistemske prvo pa nastavi.

    Code:
    sudo apt-get install libcairo2 libcairo-gobject2
    
     
  6. 0n3tw0

    Korisnik

    Joined:
    06.02.2013
    Messages:
    413
    Likes Received:
    61
    Location:
    /
    Okruženje:
    XFCE
    Sistem:
    TRIOS
    Code:
    nikola@nkl ~/novilab/cairo-1.12.14 $ sudo apt-get install libcairo2 libcairo-gobject2
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    libcairo2 is already the newest version.
    libcairo-gobject2 is already the newest version.
    You might want to run 'apt-get -f install' to correct these:
    The following packages have unmet dependencies:
    libcairo2 : Breaks: libcairo2:i386 (!= 1.12.14-0ubuntu1nikola2) but 1.12.14-0ubuntu1 is to be installed
    libcairo2:i386 : Breaks: libcairo2 (!= 1.12.14-0ubuntu1) but 1.12.14-0ubuntu1nikola2 is to be installed
    E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
    nikola@nkl ~/novilab/cairo-1.12.14 $
     
  7. dvajedan

    Korisnik

    Joined:
    17.06.2012
    Messages:
    3,442
    Likes Received:
    575
    Pa poslušaj to da vidiš kako ide :)

    Code:
    sudo apt-get -f install
     
  8. 0n3tw0

    Korisnik

    Joined:
    06.02.2013
    Messages:
    413
    Likes Received:
    61
    Location:
    /
    Okruženje:
    XFCE
    Sistem:
    TRIOS
    da izbrisem ove:

    Code:
    libcairo2:i386 i libcairo2:i386
    ?

    probao sam, i isto mi napise.
     
  9. dvajedan

    Korisnik

    Joined:
    17.06.2012
    Messages:
    3,442
    Likes Received:
    575
    Ne briši ništa nego prvo popravi te broken, probaj iz synaptica ako moraš.
     
  10. cybermanic

    Korisnik

    Joined:
    10.05.2013
    Messages:
    175
    Likes Received:
    17
    Location:
    Novi Sad
    Okruženje:
    XFCE
    Sistem:
    Mint
    Ono kad pogledaš, nisu ti fontovi ni tako ružni. :wacko3:
     
  11. 0n3tw0

    Korisnik

    Joined:
    06.02.2013
    Messages:
    413
    Likes Received:
    61
    Location:
    /
    Okruženje:
    XFCE
    Sistem:
    TRIOS
    hahhahaha :D

    meni bi uzasno bilo sada zao da ovo ne proradi. obojica smo ulozili bas dosta vremena.
     
  12. dvajedan

    Korisnik

    Joined:
    17.06.2012
    Messages:
    3,442
    Likes Received:
    575
    Yep :connie_pumpkinsmile: , pogotovo kad čovek pogleda šta oni nenormalni Ubunterosi preporučuju za troubleshooting :wacko3:

    https://help.ubuntu....ootingProcedure

    Pogotovo ovo, rokni mu dvajes komande i ima da ti proradi :connie_pumpkinsmile:

    https://help.ubuntu.com/community/PackageManagerTroubleshootingProcedure#Step_9_Ubuntu_Software_Center_fails_to_open

    Ajd @0n3tw0 synaptic gde je, si našao broken preko njega?
     
  13. 0n3tw0

    Korisnik

    Joined:
    06.02.2013
    Messages:
    413
    Likes Received:
    61
    Location:
    /
    Okruženje:
    XFCE
    Sistem:
    TRIOS
    da, kroz synaptic pokazuje da su ta dva broken. sada cu da ih ispravim
     
  14. cybermanic

    Korisnik

    Joined:
    10.05.2013
    Messages:
    175
    Likes Received:
    17
    Location:
    Novi Sad
    Okruženje:
    XFCE
    Sistem:
    Mint
    Al što su lepo pojasnili :

    Tip: If you have a wheel mouse or 3 button mouse you do not need to type commands into the Terminal.
    Ja imam 8 tastera, onda se aFtomatski pečuje kad stisnem tastere 7 i 8 ? :lol:

    :mamba:Koji su carevi , ako nemaš tri tastera ili točkić, moraš svaku komandu ručno kucati ? :lol:
     
  15. dvajedan

    Korisnik

    Joined:
    17.06.2012
    Messages:
    3,442
    Likes Received:
    575
    Meni žao što ne koristite debian, pa da vi dadnem paketiće samo :empathy: . Mada ovaj bug imaju sve distribucije, baš sve osim mene. :air_kiss:

    Cure fontovčići osam meseci diljem distro univerzijade :connie_pumpkinsmile:

    Fiksni ga, mislim apt iz synaptica, pa nastavi sa onim

    Code:
    sudo apt-get build-dep cairo:i386
     
  16. cybermanic

    Korisnik

    Joined:
    10.05.2013
    Messages:
    175
    Likes Received:
    17
    Location:
    Novi Sad
    Okruženje:
    XFCE
    Sistem:
    Mint
    Meni to ne treba, ja volonterski pridržavam moral.
     
  17. 0n3tw0

    Korisnik

    Joined:
    06.02.2013
    Messages:
    413
    Likes Received:
    61
    Location:
    /
    Okruženje:
    XFCE
    Sistem:
    TRIOS
    dvajedan, malo se zakomplikovalo sada..

    ne znam kako da objasnim, a ipak da uprostim...


    kada odem u synaptic ova dva fajla su bila broken:

    Code:
    libcairo2 i libcairo2:i386
    kada odem da ih popravim sa vec poznatom alatkom, on mi kaze sta ce sve da ukloni, a ono sto je na listi mi se nikako ne dopada.
     
  18. Dragan

    Staff Member

    Joined:
    13.01.2012
    Messages:
    7,244
    Likes Received:
    4,817
    Location:
    jóhonaaʼéí
    Okruženje:
    XFCE
    Sistem:
    TRIOS
    Zar nije moglo prosto?
    Code:
    dpkg --add-architecture i386
    
     
  19. dvajedan

    Korisnik

    Joined:
    17.06.2012
    Messages:
    3,442
    Likes Received:
    575
    Nope, to već ima čim mu

    http://forum.opensou...__40#entry30995

    Kontam da je imao je već i386 cairo odnekud, pre svega ovoga. Da je Pera otišao pravo u policiju, tj, da je čist amd64 do ovoga ne bi ni došlo :).

    Jel ti prolazi ovako:

    Code:
    sudo apt-get install libcairo2 libcairo2:i386
     
  20. 0n3tw0

    Korisnik

    Joined:
    06.02.2013
    Messages:
    413
    Likes Received:
    61
    Location:
    /
    Okruženje:
    XFCE
    Sistem:
    TRIOS
    kada popravim te, dve stvari:

    Code:
    libcairo2 i libcairo2:i386
    on popravi libcairo 2 [pozeleni onaj kvadratic] ali libcairo2:i386 ne pozeleni nego mi kaze kada udarim na apply:

    to be removed:

    festige
    festige-backend:i386
    libcairo2:i386
    libgtk2.0-0:i386
    libpango1.0-0:i386

    meni je ovaj festige potreban